Opened 5 years ago

Closed 5 years ago

#3975 defect closed duplicate (duplicate)

backtrace on canceled test

Reported by: robertc Owned by:
Priority: normal Milestone:
Component: trial Keywords:
Cc: Branch:
Author: Launchpad Bug:

Description

I hit control-C while running tests in trial.

While trial should stop on control-C, a backtrace isn't that useful. I'd suggest that:

  • the current test have a failure with the exception I caused logged
  • the test suite stop immediately
  • control return to the consol.e

File "/usr/bin/trial", line 24, in <module>

run()

File "/usr/lib/python2.6/dist-packages/twisted/scripts/trial.py", line 361, in run

test_result = trialRunner.run(suite)

File "/usr/lib/python2.6/dist-packages/twisted/trial/runner.py", line 813, in run

return self._runWithoutDecoration(test)

File "/usr/lib/python2.6/dist-packages/twisted/trial/runner.py", line 839, in _runWithoutDecoration

run()

File "/usr/lib/python2.6/dist-packages/twisted/trial/runner.py", line 834, in <lambda>

run = lambda: suite.run(result)

File "/usr/lib/python2.6/dist-packages/twisted/trial/runner.py", line 291, in run

TestSuite.run(self, result)

File "/usr/lib/python2.6/dist-packages/twisted/trial/unittest.py", line 1496, in run

Change History (2)

comment:1 Changed 5 years ago by exarkun

  • Resolution set to duplicate
  • Status changed from new to closed

This is basically a duplicate of #628. That ticket also points out that sometimes you get a traceback and the tests don't stop running.

comment:2 Changed 3 years ago by <automation>

  • Owner jml deleted
Note: See TracTickets for help on using tickets.