Opened 7 years ago

Closed 7 years ago

#3958 enhancement closed duplicate (duplicate)

EMFILE should be reported to protocol factories so that they can do something about it.

Reported by: Glyph Owned by:
Priority: normal Milestone:
Component: core Keywords:
Cc: Itamar Turner-Trauring Branch:
Author:

Description

#662 made it so that Twisted wouldn't crash any more when running out of file descriptors; we should add the ability to allow application code do something smart (like close a file descriptor) when this condition occurs.

(I feel like this should be a duplicate of something, but #662's closure message doesn't refer to any.)

Change History (4)

comment:1 Changed 7 years ago by Itamar Turner-Trauring

I'm pretty sure #662 fixed one potential "crash" condition, but that there are others (some are DoS). For example, if you're not hitting the process FD limit but have hit select()'s limit.

comment:2 Changed 7 years ago by Itamar Turner-Trauring

Cc: Itamar Turner-Trauring added

As far as this bug is concerned, EMFILE is one condition for notification, but hitting reactor limit should be another.

comment:3 Changed 7 years ago by Jean-Paul Calderone

Resolution: duplicate
Status: newclosed

Duplicate of #2122.

comment:4 Changed 6 years ago by <automation>

Owner: Jean-Paul Calderone deleted
Note: See TracTickets for help on using tickets.