Opened 8 years ago

Closed 8 years ago

#3952 defect closed duplicate (duplicate)

HTTPClientFactory follows redirect after POST by reposting, instead of GET'ing new URL

Reported by: truekonrads Owned by:
Priority: normal Milestone:
Component: web Keywords:
Cc: Branch:
Author:

Description

When a browser encounters a 30X redirect after POST, it issues a GET request to the new address. http client as generated by HTTPClientFactory however, continues to use POST.

Change History (2)

comment:1 Changed 8 years ago by Jean-Paul Calderone

Resolution: duplicate
Status: newclosed

Duplicate of #3624

comment:2 Changed 7 years ago by <automation>

Owner: jknight deleted
Note: See TracTickets for help on using tickets.