Opened 8 years ago

Closed 8 years ago

#3938 enhancement closed duplicate (duplicate)

Add support for clients in strports

Reported by: esteve Owned by:
Priority: low Milestone:
Component: core Keywords:
Cc: Branch:
Author:

Description

strports only supports returning servers, but clients in twisted.application.internet also implement the IService interface. It'd be nice to be able to create clients and connect to servers using the same syntax.

Attachments (1)

3938-strports-client.patch (2.5 KB) - added by esteve 8 years ago.

Download all attachments as: .zip

Change History (4)

Changed 8 years ago by esteve

Attachment: 3938-strports-client.patch added

comment:1 Changed 8 years ago by esteve

Keywords: review added
Owner: Glyph deleted

This patch simply replicates the behavior in listen() and service() with connect() and client(). There aren't any tests for the already existing code (apart from testing parse), so I didn't add any for the code in the patch, should I write them?

comment:2 Changed 8 years ago by Jean-Paul Calderone

Keywords: review removed
Resolution: duplicate
Status: newclosed

Yes, definitely, all code must have at least complete line coverage. :)

Also, this is a duplicate of #511. Attach the next patch there, and feel the excitement of helping close a three-digit-number ticket. :)

comment:3 Changed 7 years ago by <automation>

Note: See TracTickets for help on using tickets.