Opened 8 years ago

Closed 6 years ago

#3927 defect closed duplicate (duplicate)

twisted.conch.scripts.cftp chunk copying can result in "RuntimeError: maximum recursion depth exceeded"

Reported by: Drew Smathers Owned by: Drew Smathers
Priority: normal Milestone:
Component: conch Keywords: cftp ssh conch
Cc: Thijs Triemstra Branch:
Author:

Description

Unless buffersize' and a request' arguments are carefully adjusted, "maximum recursion depth exceeded" can occur inside of StdioClient._cbPutWrite when copying large files (~155MB if requests=10 and buffersize=48KB, for example). Please see attached patch.

Attachments (1)

cftp.py.diff (1.4 KB) - added by Drew Smathers 8 years ago.

Download all attachments as: .zip

Change History (3)

Changed 8 years ago by Drew Smathers

Attachment: cftp.py.diff added

comment:1 Changed 8 years ago by Thijs Triemstra

Cc: Thijs Triemstra added
Owner: changed from z3p to Drew Smathers

Hi djroofy, thanks for the patch. The TwistedDevelopment policy requires unit tests for any changes, could you supply those as well?

comment:2 Changed 6 years ago by Jean-Paul Calderone

Resolution: duplicate
Status: newclosed

This looks like a duplicate of #1589.

Note: See TracTickets for help on using tickets.