Opened 8 years ago

Closed 8 years ago

#3915 enhancement closed duplicate (duplicate)

spawnProcess docs could be clearer

Reported by: robertc Owned by:
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch:
Author:

Description

http://twistedmatrix.com/documents/current/api/twisted.internet.interfaces.IProcessProtocol.html says " env the environment variables to pass to the processs; a dictionary of strings. If 'None', use os.environ. "

If, instead, it said " env the environment variables to pass to the processs; a dictionary of strings. If 'None', use os.environ. The default is to pass no environment variables to the process, which is probably not what you need."

Change History (3)

comment:1 Changed 8 years ago by Jean-Paul Calderone

The env parameter to spawnProcess is quite tragic. The above documentation is correct for POSIX, but incorrect for Windows.

This interface would benefit significantly from a new method with more consistent cross-platform semantics. There are a number of other tickets in this area. See #2787, #2480, #1123, #3226, and #2415 (one of which this ticket may be a duplicate of).

comment:2 Changed 8 years ago by jesstess

Resolution: duplicate
Status: newclosed

Duplicate of #3480

comment:3 Changed 7 years ago by <automation>

Owner: Glyph deleted
Note: See TracTickets for help on using tickets.