Opened 9 years ago

Closed 9 years ago

Last modified 5 years ago

#3858 enhancement closed duplicate (duplicate)

Add a mechanism for viewing the state and history of a deferred's callbacks as an optional debugging mode

Reported by: radix Owned by:
Priority: low Milestone:
Component: core Keywords: deferred
Cc: terrycojones, teratorn@… Branch:
Author:

Description

Terry Jones implemented a nice class for tracking deferred history to help debugging strange Deferred problems. It'd be nice to test this code and integrate it into the core of Twisted, with something like defer.setHistoryTracking(True) to turn it on.

The original mailing list post is here:

http://www.twistedmatrix.com/pipermail/twisted-python/2008-October/018535.html

Change History (6)

comment:1 Changed 9 years ago by Glyph

Owner: changed from Glyph to radix
Priority: normallow

Feel free :).

comment:2 Changed 9 years ago by terrycojones

Cc: terrycojones added

comment:3 Changed 9 years ago by terrycojones

It would be nice to add simple timing information to the history too (when was a callback func added, when was it called, when did it return). That would perhaps be of some assistance to people trying to understand how much time was spent on what during the execution of a deferred. The history function (that gets inserted in the callback chain) could then print the timing info.

comment:4 Changed 9 years ago by Jean-Paul Calderone

Resolution: duplicate
Status: newclosed

This is a duplicate of #1402.

comment:5 Changed 7 years ago by <automation>

Owner: radix deleted

comment:6 Changed 5 years ago by teratorn

Cc: teratorn@… added
Keywords: deferred added
Note: See TracTickets for help on using tickets.