Opened 5 years ago

Closed 3 years ago

#3839 task closed duplicate (duplicate)

Add release procedure document

Reported by: thijs Owned by:
Priority: normal Milestone: totally automated release infrastructure
Component: core Keywords: documentation
Cc: thijs, jesstess, khorn Branch:
Author: Launchpad Bug:

Description

There aren't any documents that describe a proper release procedure as far as I know, except for this old page, so would be good to have something like a release policy document describing things like how and when bump the version number, otherwise we might run into issues again.

Change History (7)

comment:1 Changed 5 years ago by exarkun

  • Keywords documentation added
  • Owner changed from glyph to radix
  • Summary changed from Add release policy document to Add release procedure document

comment:2 Changed 5 years ago by thijs

comment:3 Changed 5 years ago by jesstess

  • Cc jesstess added

comment:4 Changed 5 years ago by khorn

  • Cc khorn added

comment:5 Changed 4 years ago by khorn

This page is currently the most complete description of the release process. It should probably be migrated from the wiki into the documentation proper once it's been nailed down a little further.

comment:6 Changed 3 years ago by <automation>

  • Owner radix deleted

comment:7 Changed 3 years ago by thijs

  • Resolution set to duplicate
  • Status changed from new to closed

Marking it as a duplicate of #4543 (ReleaseProcess fixed this ticket also).

Note: See TracTickets for help on using tickets.