Opened 9 years ago

Closed 9 years ago

#3826 enhancement closed duplicate (duplicate)

ZipPath patch so that plugins works with non-writable plugins cache

Reported by: grossetti Owned by:
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch:
Author:

Description

As described in the email thread Twisted plugins and py2exe, I had problems using plugins with py2exe when the files are compressed in a Zip archive. A potential solution was to patch plugin.py to not try to update the cache file (or not creating it at all), btu that wasn't seen as a good solution. Another solution was to have py2exe create the cache and copy the cache files into the Zip archive, this is the path I took. While implementing this, I ran into a small problem, the open() funtion's signature is not the same in twisted.python.filepath.FilePath as it is in twisted.python.zippath.ZipPath and so I got exceptions. The patch I am submitting make's ZipPath's open function take an optional mode param and makes sure only read-only modes are passed. Also, if there could be a page in the wiki concerning py2exe it would be great, it could explain the code to make py2exe & Twisted w/ plugins behave like expected. I also joined a py2exe setup.py example on how to do that. This ticket is in some ways related to tickets #996 & #2409

Change History (2)

comment:1 Changed 9 years ago by Glyph

Resolution: duplicate
Status: newclosed

This is a duplicate of #3827.

(Closing the lower ticket as a duplicate since the other ticket has the patch.)

comment:2 Changed 7 years ago by <automation>

Owner: Glyph deleted
Note: See TracTickets for help on using tickets.