Opened 9 years ago

Closed 9 years ago

#3743 defect closed duplicate (duplicate)

On windows, skip pywin32 tests if it is not available

Reported by: christianmlong Owned by:
Priority: normal Milestone:
Component: core Keywords:
Cc: Thijs Triemstra Branch:
Author: Christian Long

Description

The following tests fail on Windows if pywin32 is not installed. In the spirit of #3707, skip these tests if not implements IReactorProcess.

twisted.internet.test.test_process.ProcessTestsBuilder_SelectReactor.test_childConnectionLost
twisted.internet.test.test_process.ProcessTestsBuilder_SelectReactor.test_processEnded
twisted.internet.test.test_process.ProcessTestsBuilder_SelectReactor.test_processExited
twisted.internet.test.test_process.ProcessTestsBuilder_SelectReactor.test_processExitedWithSignal
twisted.test.test_application.PluggableReactorTestCase.test_qtStub
twisted.test.test_stdio.StandardInputOutputTestCase.test_consumer
twisted.test.test_stdio.StandardInputOutputTestCase.test_hostAndPeer
twisted.test.test_stdio.StandardInputOutputTestCase.test_loseConnection
twisted.test.test_stdio.StandardInputOutputTestCase.test_producer
twisted.test.test_stdio.StandardInputOutputTestCase.test_write
twisted.test.test_stdio.StandardInputOutputTestCase.test_writeSequence


exceptions.NotImplementedError: spawnProcess not available since pywin32 is not installed.

Change History (2)

comment:1 Changed 9 years ago by Thijs Triemstra

Cc: Thijs Triemstra added
Resolution: duplicate
Status: newclosed

This looks like a duplicate of #3707?

comment:2 Changed 7 years ago by <automation>

Owner: Glyph deleted
Note: See TracTickets for help on using tickets.