Opened 9 years ago

Closed 8 years ago

#3734 defect closed duplicate (duplicate)

Intermittent failure of twisted.test.test_tcp.LocalRemoteAddressTestCase.test_hostAddress on win XP

Reported by: christianmlong Owned by:
Priority: normal Milestone:
Component: core Keywords: tests windows
Cc: Branch:
Author:

Description

Similar error to #3402, only this one is on Windows XP.

===============================================================================
[FAIL]: twisted.test.test_tcp.LocalRemoteAddressTestCase.test_hostAddress

Traceback (most recent call last):
  File twisted\test\test_tcp.py, line 917, in check
    self.assertEquals([port.getHost()], clientFactory.peerAddresses)
twisted.trial.unittest.FailTest: not equal:
a = [<twisted.internet.address.IPv4Address object at 0x011D84D0>]
b = [<twisted.internet.address.IPv4Address object at 0x011D8450>]

===============================================================================
[ERROR]: twisted.test.test_tcp.LocalRemoteAddressTestCase.test_hostAddress

Traceback (most recent call last):
Failure: twisted.trial.util.DirtyReactorAggregateError: Reactor was unclean.
Selectables:
<MyProtocol #0 on 2966>
<<class 'twisted.internet.tcp.Client'> to ('127.0.0.1', 2966) at 11d81d0>
-------------------------------------------------------------------------------

Change History (2)

comment:1 Changed 8 years ago by Glyph

Resolution: duplicate
Status: newclosed

This looks like a effectively a duplicate of #3402; I believe the fix for that fixed this as well.

comment:2 Changed 7 years ago by <automation>

Owner: Glyph deleted
Note: See TracTickets for help on using tickets.