Opened 9 years ago

Closed 8 years ago

#3665 defect closed duplicate (duplicate)

twisted.internet.test.test_posixbase.PosixReactorBaseTests leaks FDs

Reported by: radix Owned by:
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch:
Author:

Description

The following command eventually fails with a too many FDs error

trial -u twisted.internet.test.test_posixbase.PosixReactorBaseTests

That's because the tests instantiate reactors without ever cleaning up waker FDs.

Change History (2)

comment:1 Changed 8 years ago by Glyph

Resolution: duplicate
Status: newclosed

I think that this is a duplicate of #3063.

comment:2 Changed 7 years ago by <automation>

Owner: Glyph deleted
Note: See TracTickets for help on using tickets.