Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#3647 defect closed fixed (fixed)

There are many "StringIOWithoutClosing" classes in the test suite

Reported by: exarkun Owned by:
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch: branches/remove-duplicate-stringios-3647
(diff, github, buildbot, log)
Author: exarkun Launchpad Bug:

Description

There shouldn't be this kind of rampant duplication of testing helpers.

Change History (7)

comment:1 Changed 6 years ago by exarkun

  • Author set to exarkun
  • Branch set to branches/remove-duplicate-stringios-3647

(In [26200]) Branching to 'remove-duplicate-stringios-3647'

comment:2 Changed 6 years ago by exarkun

  • Keywords review added
  • Owner exarkun deleted

Build Results

Please review

comment:3 Changed 6 years ago by therve

  • Keywords review removed
  • Owner set to exarkun

I just noticed some pyflakes:

twisted/words/test/test_irc.py:8: 'StringIO' imported but unused
twisted/words/test/test_toc.py:11: 'StringIO' imported but unused
twisted/test/test_postfix.py:9: 'protocols' imported but unused
twisted/test/test_postfix.py:10: 'internet' imported but unused
twisted/test/test_postfix.py:11: 'loopback' imported but unused
twisted/test/test_postfix.py:13: 'defer' imported but unused
twisted/test/test_postfix.py:13: 'protocol' imported but unused
twisted/test/test_finger.py:10: 'protocol' imported but unused
twisted/test/test_finger.py:10: 'reactor' imported but unused
twisted/test/test_protocols.py:9: 'StringIO' imported but unused

Once fixed, please merge. Thanks!

comment:4 Changed 6 years ago by exarkun

(In [26219]) Remove unused imports

refs #3647

comment:5 Changed 6 years ago by exarkun

  • Resolution set to fixed
  • Status changed from new to closed

(In [26220]) Merge remove-duplicate-stringios-3647

Author: exarkun
Reviewer: therve
Fixes: #3647

Replace numerous duplicate definitions of the StringIOWithoutClosing utility class
with use of a single centralized definition. Also remove and replace other similar
test helper classes in favor of use of the new centralized StringIOWithoutClosing.

comment:6 Changed 4 years ago by exarkun

This was a duplicate of #3015.

comment:7 Changed 4 years ago by <automation>

  • Owner exarkun deleted
Note: See TracTickets for help on using tickets.