Opened 9 years ago

Closed 9 years ago

#3640 defect closed duplicate (duplicate)

Printing SMTPClientError raises exception

Reported by: atsuoi Owned by:
Priority: normal Milestone:
Component: mail Keywords:
Cc: Branch:
Author:

Description

I got following exception when I printed SMTPClientError.

File "C:\Python25\Lib\site-packages\twisted\internet\defer.py", line 328, in _runCallbacks

self.result = callback(self.result, *args, kw)

File "ss.py", line 56, in error

print "error", reason

File "C:\Python25\Lib\site-packages\twisted\python\failure.py", line 403, in str

return "[Failure instance: %s]" % self.getBriefTraceback()

File "C:\Python25\Lib\site-packages\twisted\python\failure.py", line 467, in getBriefTraceback

self.printBriefTraceback(file=io)

File "C:\Python25\Lib\site-packages\twisted\python\failure.py", line 529, in printBriefTraceback

self.printTraceback(file, elideFrameworkCode, detail='brief')

File "C:\Python25\Lib\site-packages\twisted\python\failure.py", line 492, in printTraceback

w("%s: %s: %s\n" % (hasFrames, self.type, self.value))

File "c:\python25\lib\site-packages\twisted\mail\smtp.py", line 157, in str

exceptions.TypeError: sequence item 2: expected string, instance found

Attached file contains a fix and an unit test.

Attachments (1)

smtperr.diff (1.2 KB) - added by atsuoi 9 years ago.

Download all attachments as: .zip

Change History (6)

Changed 9 years ago by atsuoi

Attachment: smtperr.diff added

comment:1 Changed 9 years ago by Glyph

Keywords: review added
Owner: Jean-Paul Calderone deleted

Thanks for the contribution! You should really read the page on developing for twisted so that your future contributions will be dealt with quickly. If you're looking for something to be evaluated (you've already written a patch, tests, etc) you should place it into review by adding the 'review' keyword and reassign it to nobody (the blank line at the top of the 'reassign' list).;

comment:2 Changed 9 years ago by atsuoi

Thank you for the tip. I'll read the page later!

comment:3 Changed 9 years ago by Jean-Paul Calderone

Owner: set to Jean-Paul Calderone
Status: newassigned

comment:4 Changed 9 years ago by Jean-Paul Calderone

Keywords: review removed
Resolution: duplicate
Status: assignedclosed

Duplicate of #1219.

comment:5 Changed 7 years ago by <automation>

Owner: Jean-Paul Calderone deleted
Note: See TracTickets for help on using tickets.