Opened 9 years ago

Closed 9 years ago

#3572 defect closed duplicate (duplicate)

Circular reference in twisted.internet.tcp.BaseClient

Reported by: luci Owned by:
Priority: normal Milestone:
Component: core Keywords:
Cc: therve Branch:
Author:

Description

A circular reference is created by method doConnect of twisted.internet.tcp.BaseClient: it fails to delete the references self.doRead and self.doWrite in the exit points where failIfNotConnected is called.

This is annoying when trying to debug own code which uses this class. Since the references are deleted in some exit points, I see no reason for which they wouldn't be in those where failIfNotConnected is called.

I have attached a patch which fixes this problem.

Attachments (1)

twisted_circular_reference.diff (703 bytes) - added by luci 9 years ago.
Patch which fixes circular references in twisted.internet.tcp.BaseClient

Download all attachments as: .zip

Change History (4)

Changed 9 years ago by luci

Patch which fixes circular references in twisted.internet.tcp.BaseClient

comment:1 Changed 9 years ago by therve

Cc: therve added

It's a duplicate of #2642, so I'll give the same comment: what's the reason behind this? Do you have a concrete problem? The changes should come with tests.

comment:2 Changed 9 years ago by Glyph

Resolution: duplicate
Status: newclosed

As the other ticket says, if you have a more detailed explanation of why this is a problem, please reopen #2642.

comment:3 Changed 7 years ago by <automation>

Owner: Glyph deleted
Note: See TracTickets for help on using tickets.