Ticket #3539 task closed fixed

Opened 5 years ago

Last modified 5 years ago

Drop all FAQs in the repository and merge them into the wiki FAQ page

Reported by: thijs Owned by:
Priority: normal Milestone:
Component: core Keywords: documentation
Cc: thijs Branch: branches/drop-faqs-3539
(diff, github, buildbot, log)
Author: thijs Launchpad Bug:

Description (last modified by exarkun) (diff)

We've stopped maintaining FAQs in the repository. Instead, we maintain one on the wiki - FrequentlyAskedQuestions. Some subprojects still have FAQs, though. We should remove them from the repository and put them onto the wiki.

Change History

1

  Changed 5 years ago by thijs

  • cc thijs added
  • owner changed from glyph to thijs
  • status changed from new to assigned
  • type changed from regression to task
  • summary changed from Distribute the wiki's FAQ with new releases to Drop all FAQs in the repository and merge them into the wiki FAQ page

Renamed the ticket description based on the IRC chat, pasted below:

[14:46] exarkun: thijs: How about we don't distribute the FAQ?
[14:47] thijs: what about the t.web faq.. then we should get rid of that one as well, merge it into the wiki page?
[14:48] exarkun: probably
[14:48] thijs: exarkun: sounds good not to distribute it, but lets not make an exception for any other faqs in doc/ ?
[14:48] thijs: ok
[14:48] exarkun: I would just throw away the woven faq entries, though.
[14:49] thijs: ill rename the ticket to drop any other faqs and merge them into the wiki, except for woven

2

  Changed 5 years ago by exarkun

  • description modified (diff)

The old description was:

Now that the core FAQ isn't maintained in the Subversion repository anymore (it was dropped with #3236), we could export the wiki's FrequentlyAskedQuestions page and include it in new releases.

3

  Changed 5 years ago by thijs

  • branch set to branches/drop-faqs-3539
  • branch_author set to thijs

(In [26505]) Branching to 'drop-faqs-3539'

4

  Changed 5 years ago by thijs

Some entries I'm moving from doc/web/howto/faq.xhtml to FrequentlyAskedQuestions:


Can Twisted Web do PHP?

Yes. It works out-of-the-box, so long as you've got the standalone PHP interpreter installed.

And can Twisted Web do virtual hosting?

You can decide to go with one big process for all of them, a front server and a seperate server for each virtual host (for example, for permission reasons), and you can even mix-and-match between Apache and Twisted (for example, put Apache in the front and have Twisted handle some subset of the virtual host).

5

  Changed 5 years ago by thijs

(In [26506]) Drop web faq, refs #3539

6

  Changed 5 years ago by thijs

  • status changed from assigned to new
  • keywords documentation, review added; documentation removed
  • owner thijs deleted

Putting the branch and items from comment 4 in this ticket up for review.

7

  Changed 5 years ago by thijs

 doc builder is happy as well.

8

follow-up: ↓ 9   Changed 5 years ago by exarkun

  • keywords documentation added; documentation, review removed
  • owner set to thijs

Where'd the web faq entries go? Did they just get deleted? I looked for them on the FrequentlyAskedQuestions page but did not see them. And I don't see a dedicated Web FAQ page.

9

in reply to: ↑ 8   Changed 5 years ago by thijs

  • owner changed from thijs to exarkun
  • keywords documentation, review added; documentation removed

Replying to exarkun:

Where'd the web faq entries go? Did they just get deleted? I looked for them on the FrequentlyAskedQuestions page but did not see them. And I don't see a dedicated Web FAQ page.

I only found 2 entries from that FAQ that seemed helpful. They're listed in comment 4 of this ticket. Since there are only 2 entries I don't think it's necessary to create a dedicated FAQ page for web. Putting it up for review, let me know your thoughts, cheers.

10

  Changed 5 years ago by exarkun

  • owner changed from exarkun to thijs
  • keywords documentation added; documentation, review removed

I think it's fine to create a FAQ with just two entries on it. It'll grow more entries eventually. :) So if you agree, go ahead and create a FAQ for those and merge the branch.

11

  Changed 5 years ago by thijs

  • status changed from new to assigned

12

  Changed 5 years ago by thijs

  • status changed from assigned to closed
  • resolution set to fixed

(In [26589]) Merge drop-faqs-3539: drop the last faq in the repository and merge it into the TwistedWeb/FrequentlyAskedQuestions wiki page.

Author: thijs Reviewer: exarkun Fixes: #3539

13

  Changed 3 years ago by <automation>

  • owner thijs deleted
Note: See TracTickets for help on using tickets.