Opened 9 years ago

Closed 9 years ago

Last modified 15 months ago

#3485 enhancement closed duplicate (duplicate)

Add line numbers to Python listings in documentation

Reported by: kehander1 Owned by:
Priority: normal Milestone:
Component: lore Keywords:
Cc: Branch:
Author:

Description

Line numbers in Python listings in the documentation would make it easier to refer to individual lines. It might be argued that such line numbers can easily go out of sync, but since the example listings don't get edited all that often, this does not strike me as much of a concern.

The attached change is a rather brazen kludge, though it does work. When spaces show up at the start of a line (in order to pad the line numbers), lore complains about indentation levels not matching - so this fix precedes the line number with a null character (ALT+255).

Change History (3)

comment:1 Changed 9 years ago by Thijs Triemstra

Resolution: duplicate
Status: newclosed

Duplicate of #3486 which includes the actual patch.

comment:2 Changed 7 years ago by <automation>

Owner: spiv deleted

comment:3 Changed 15 months ago by hawkowl

Keywords: review removed

[mass edit] Removing review from closed tickets.

Note: See TracTickets for help on using tickets.