Opened 9 years ago

Closed 9 years ago

Last modified 15 months ago

#3474 defect closed duplicate (duplicate)

twistd shouldn't install a timer service

Reported by: zseil Owned by:
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch:
Author:

Description

On Windows, twistd installs a timer service. That service is not needed, since the reactors already have workarounds for lack of signal interrupts in select.

The patch also removes a log line, because the same line is already produced by twisted.app.AppLogger.

Attachments (1)

remove-twistd-time-service.patch (2.5 KB) - added by zseil 9 years ago.
patch, v1

Download all attachments as: .zip

Change History (4)

Changed 9 years ago by zseil

patch, v1

comment:1 Changed 9 years ago by therve

Resolution: duplicate
Status: newclosed

This is a duplicate of #1764

comment:2 Changed 7 years ago by <automation>

Owner: Glyph deleted

comment:3 Changed 15 months ago by hawkowl

Keywords: review removed

[mass edit] Removing review from closed tickets.

Note: See TracTickets for help on using tickets.