Opened 6 years ago

Closed 6 years ago

#3433 defect closed duplicate (duplicate)

twisted.trial.runner.TrialRunner unconditionally prints warnings to stdout

Reported by: exarkun Owned by:
Priority: normal Milestone:
Component: trial Keywords:
Cc: Branch:
Author: Launchpad Bug:

Description

TrialRunner makes it possible to see Twisted log messages which are emitted by the log/warnings bridge code. It does this by printing the warning to stdout. If a test needs to emit a warning of this type, there is no way to prevent having the warning written to stdout. Normal behavior such as this which is expected and required should not result in noise on stdout. There should be a way to prevent these warnings from showing up.

Change History (3)

comment:1 Changed 6 years ago by exarkun

(In [24808]) note about how this can't be improved right now

refs #3433
refs #3211

comment:2 Changed 6 years ago by exarkun

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #2820

comment:3 Changed 4 years ago by <automation>

  • Owner jml deleted
Note: See TracTickets for help on using tickets.