Opened 9 years ago

Closed 9 years ago

#3416 enhancement closed fixed (fixed)

rename `twisted.web2.iweb.IOldRequest` to `twisted.web.iweb.IRequest`

Reported by: Jean-Paul Calderone Owned by:
Priority: normal Milestone:
Component: web Keywords:
Cc: Thijs Triemstra Branch: branches/iresource-3416-2
branch-diff, diff-cov, branch-cov, buildbot
Author: exarkun

Description

twisted.web has been missing IRequest for quite a while. Apparently it is almost already defined in twisted.web2. The definition belongs in twisted.web, though.

Change History (11)

comment:1 Changed 9 years ago by Jean-Paul Calderone

author: exarkun
Branch: branches/iresource-3416

(In [24761]) Branching to 'iresource-3416'

comment:2 Changed 9 years ago by Jean-Paul Calderone

Keywords: review added
Owner: Jean-Paul Calderone deleted

Moved

comment:3 Changed 9 years ago by Thijs Triemstra

Cc: Thijs Triemstra added
Keywords: review removed
Owner: set to Jean-Paul Calderone

What about @since tags? Or am I missing something here..

comment:4 Changed 9 years ago by Jean-Paul Calderone

Keywords: review added
Owner: Jean-Paul Calderone deleted

Good catch, thanks. :) Hopefully after you correct me on that two or three more times I'll start to remember on my own.

This is a bit tricky, since the interface itself is new, but it documents something that's old, except some of the attributes are actually also new. So I guess I'm going to do the safe thing and just say it's since 8.2.

Thanks for the review (not sure if that was meant to be a whole review or if you just wanted to point out that one thing, so putting it back up for review).

comment:5 in reply to:  4 Changed 9 years ago by Thijs Triemstra

Keywords: review removed
Owner: set to Jean-Paul Calderone

Replying to exarkun:

Good catch, thanks. :) Hopefully after you correct me on that two or three more times I'll start to remember on my own.

Yep thats the plan :)

Thanks for the review (not sure if that was meant to be a whole review or if you just wanted to point out that one thing, so putting it back up for review).

Yeah, just wanted to point out that thing. Another thing though, while working on #1852 I noticed some methods in this interface lack docstrings and have redundant pass statements. Can you fix that or is #1852 a more appropriate ticket for that.

comment:6 Changed 9 years ago by Jean-Paul Calderone

Branch: branches/iresource-3416branches/iresource-3416-2

(In [25068]) Branching to 'iresource-3416-2'

comment:7 Changed 9 years ago by Jean-Paul Calderone

#3273 was a duplicate of this ticket.

comment:8 Changed 9 years ago by Jean-Paul Calderone

Keywords: review added
Owner: Jean-Paul Calderone deleted

This seems to be ready for another review.

comment:9 Changed 9 years ago by therve

Keywords: review removed
Owner: set to Jean-Paul Calderone

It looks good, please merge.

comment:10 Changed 9 years ago by Jean-Paul Calderone

Resolution: fixed
Status: newclosed

(In [25888]) Merge iresource-3416-2

Author: exarkun Reviewer: thijs, therve Fixes: #3416

Add twisted.web.iweb.IRequest defining the interface provided by request objects in Twisted Web.

comment:11 Changed 7 years ago by <automation>

Owner: Jean-Paul Calderone deleted
Note: See TracTickets for help on using tickets.