Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#3406 enhancement closed invalid (invalid)

Add --quiet option to Trial

Reported by: thijs Owned by:
Priority: normal Milestone:
Component: trial Keywords:
Cc: thijs Branch:
Author: Launchpad Bug:

Description

While testing trial --rterrors twisted on a device with very limited memory, it would eventually crash, most likely due to the memory limitation when trying to print the results to screen and write them to file. On unix a workaround would be trial --rterrors twisted > file.txt but this doesn't catch the warnings at startup:

/private/var/mobile/dev/software/twisted/twisted/conch/ssh/common.py:18: RuntimeWarning: PyCrypto not installed, but continuing anyways!
  RuntimeWarning)
/private/var/mobile/dev/software/twisted/twisted/python/reflect.py:391: DeprecationWarning: twisted.flow is unmaintained.
  return __import__(importName)
/private/var/mobile/dev/software/twisted/twisted/scripts/test/test_mktap.py:16: DeprecationWarning: mktap and related support modules are deprecated as of Twisted 8.0.  Use Twisted Application Plugins with the 'twistd' command directly, as described in 'Writing a Twisted Application Plugin for twistd' chapter of the Developer Guide.
  from twisted.scripts.mktap import run, getid
/private/var/mobile/dev/software/twisted/twisted/enterprise/util.py:19: DeprecationWarning: twisted.enterprise.util is deprecated since Twisted 8.0.0.
  category=DeprecationWarning)
/private/var/mobile/dev/software/twisted/twisted/test/test_persisted.py:161: DeprecationWarning: twisted.persisted.marmalade is deprecated
  from twisted.persisted import marmalade
/private/var/mobile/dev/software/twisted/twisted/words/im/__init__.py:8: UserWarning: twisted.im will be undergoing a rewrite at some point in the future.
  warnings.warn("twisted.im will be undergoing a rewrite at some point in the future.")

So perhaps something like a --quiet option, that will also not print anything to file unless I supplied the --logfile=log.txt option?

Change History (5)

comment:1 Changed 6 years ago by thijs

  • Component changed from core to trial
  • Owner changed from glyph to jml

comment:2 Changed 6 years ago by glyph

  • Resolution set to invalid
  • Status changed from new to closed

This doesn't sound very well specified. Presumably if you run trial you want it to produce some output. Maybe you mean --only-failures or something, I don't know; but if your iphone crashes then the problem is that your iphone crashes, let's not add features to trial unless they solve a specific problem.

comment:3 Changed 6 years ago by exarkun

Additionally, trial --reporter=summary should already cover this case.

comment:4 Changed 6 years ago by thijs

Also noticed #3003 just now :)

comment:5 Changed 3 years ago by <automation>

  • Owner jml deleted
Note: See TracTickets for help on using tickets.