Opened 9 years ago

Closed 9 years ago

#3351 defect closed duplicate (duplicate)

Examples for DefferedList are out of date

Reported by: mim Owned by:
Priority: normal Milestone:
Component: core Keywords: documentation DefferedList
Cc: termim Branch:
Author:

Description

The example code for DefferedList gives DeprecationWarning in Twisted-8.1.0:

/usr/lib/python2.5/site-packages/twisted/internet/defer.py:267: DeprecationWarning: Don't pass strings (like 'bang!') to failure.Failure (replacing with a DefaultException).
  fail = failure.Failure(fail)
[(True, 'one'), (False, <twisted.python.failure.Failure <class 'twisted.python.failure.DefaultException'>>), (True, 'three')]
Unhandled error in Deferred:
Traceback (most recent call last):
Failure: twisted.python.failure.DefaultException: bang!

Also this page says that the result list for DefferedList consists of tuples where the first element is integer while in 8.1.0 it is boolean instead. May be nitpicking but ...

Change History (2)

comment:1 Changed 9 years ago by Jean-Paul Calderone

Resolution: duplicate
Status: newclosed

Duplicate of #3323

comment:2 Changed 7 years ago by <automation>

Owner: Glyph deleted
Note: See TracTickets for help on using tickets.