Opened 9 years ago

Closed 9 years ago

#3337 defect closed duplicate (duplicate)

manhole exception: AttributeError: 'module' object has no attribute '__getattr__'

Reported by: doko Owned by:
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch:
Author:

Description (last modified by therve)

seen with 8.1.0 and python2.5:

$ cd /home/packages/twisted/
doko@salsa:/home/packages/twisted$ schroot -p -c sid32
I: [sid32 chroot] Running shell: '/bin/bash'
(sid32)doko@salsa:/home/packages/twisted$ manhole
Traceback (most recent call last):
  File "/usr/bin/manhole", line 21, in <module>
    manhole.run()
  File "/usr/lib/python2.5/site-packages/twisted/scripts/manhole.py", line 102, in run
    run(config)
  File "/usr/lib/python2.5/site-packages/twisted/scripts/manhole.py", line 154, in run_gtk2
    w = gtk2manhole.ManholeWindow()
  File "/usr/lib/python2.5/site-packages/twisted/manhole/ui/gtk2manhole.py", line 46, in __init__
    self.input = ConsoleInput(self._input)
  File "/usr/lib/python2.5/site-packages/twisted/manhole/ui/gtk2manhole.py", line 218, in __init__
    self.rkeymap[getattr(gtk.keysyms, name)] = name
AttributeError: 'module' object has no attribute '__getattr__'

Change History (2)

comment:1 Changed 9 years ago by therve

Description: modified (diff)
Resolution: duplicate
Status: newclosed

This is a duplicate of #2464.

comment:2 Changed 7 years ago by <automation>

Owner: Glyph deleted
Note: See TracTickets for help on using tickets.