Opened 6 years ago

Closed 6 years ago

#3311 defect closed duplicate (duplicate)

Don't rely on gc details

Reported by: fijal Owned by:
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch:
Author: Launchpad Bug:

Description

Exploding deferred info is added to log by DebugInfo.del. This is a bad choice in the first place I think, but moreover, tests are relying on stuff being there immediately. (like twisted.test.test_defer.LogTestCase). It's easy to fix this particular test, but I think it's a bit deeper.

Attachments (1)

x.diff (442 bytes) - added by fijal 6 years ago.

Download all attachments as: .zip

Change History (4)

comment:1 Changed 6 years ago by fijal

I got convinced that del should stay. A patch for calling gc.collect.

Changed 6 years ago by fijal

comment:2 Changed 6 years ago by fijal

  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #3318

comment:3 Changed 4 years ago by <automation>

  • Owner glyph deleted
Note: See TracTickets for help on using tickets.