Opened 10 years ago

Closed 9 years ago

#3274 enhancement closed duplicate (duplicate)

Replace DummyRequest with a verified fake of Request

Reported by: Jean-Paul Calderone Owned by:
Priority: normal Milestone:
Component: web Keywords:
Cc: Branch:
Author:

Description

DummyRequest does not implement the same interface as Request and it doesn't have the same behavior as Request for some of the interface that it does implement. Tests based on DummyRequest aren't necessarily valid.

Change History (2)

comment:1 Changed 9 years ago by Jean-Paul Calderone

Resolution: duplicate
Status: newclosed

This is a duplicate of #3091.

comment:2 Changed 7 years ago by <automation>

Owner: jknight deleted
Note: See TracTickets for help on using tickets.