Opened 10 years ago

Closed 9 years ago

#3273 enhancement closed duplicate (duplicate)

define IRequest for twisted.web

Reported by: Jean-Paul Calderone Owned by:
Priority: normal Milestone:
Component: web Keywords:
Cc: Branch:
Author:

Description

It'd be nice to know what the reasonable set of methods on request objects is. A lot of methods on request are trivial convenience functions which don't really need to be part of the core interface. It would also be useful to separate the resource-facing APIs from the protocol-facing APIs.

Attachments (1)

iweb.py (1.5 KB) - added by Jean-Paul Calderone 10 years ago.
minimal first attempt

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by Jean-Paul Calderone

Attachment: iweb.py added

minimal first attempt

comment:1 Changed 10 years ago by Glyph

+1000000000000000000000000000000000000

comment:2 Changed 9 years ago by Jean-Paul Calderone

Resolution: duplicate
Status: newclosed

#3416 was apparently a duplicate of this. A bunch more work has been done there, though, so closing this ticket, even though it's the older of the two.

comment:3 Changed 7 years ago by <automation>

Owner: jknight deleted
Note: See TracTickets for help on using tickets.