Opened 10 years ago

Closed 9 years ago

#3243 defect closed duplicate (duplicate)

Invalid Syntax while installation of Twisted 8.0.1

Reported by: jprakashonnet Owned by:
Priority: normal Milestone:
Component: core Keywords:
Cc: Jean-Paul Calderone, Thijs Triemstra Branch:
Author:

Description (last modified by therve)

creating 'dist\Twisted-8.0.1-py2.4-win32.egg' and adding 'build\bdist.win32\egg'
 to it
removing 'build\bdist.win32\egg' (and everything under it)
Processing Twisted-8.0.1-py2.4-win32.egg
removing 'c:\program files\plone 3\python\lib\site-packages\Twisted-8.0.1-py2.4-
win32.egg' (and everything under it)
creating c:\program files\plone 3\python\lib\site-packages\Twisted-8.0.1-py2.4-w
in32.egg
Extracting Twisted-8.0.1-py2.4-win32.egg to c:\program files\plone 3\python\lib\
site-packages
  File "c:\program files\plone 3\python\lib\site-packages\Twisted-8.0.1-py2.4-wi
n32.egg\twisted\test\generator_failure_tests.py", line 66
    yield
         ^
SyntaxError: invalid syntax

Attachments (1)

exec.diff (867 bytes) - added by ghazel 9 years ago.
exec-based answer

Download all attachments as: .zip

Change History (13)

comment:1 Changed 10 years ago by therve

Description: modified (diff)

Can you please explain the problem? Does the installation fail? How do you launch the installation? What's your platform?

comment:2 Changed 10 years ago by Jean-Paul Calderone

Milestone: Twisted-8.1

comment:3 Changed 10 years ago by collab

I've also seen this before. It doesn't fail the installation, it's not on Windows only (although he's using win from the looks of it) and I'm not sure if it's Python 2.4 only but most likely is. Sorry I can't give more info, just wanted to confirm he's not the only one that noticed this warning.

comment:4 Changed 9 years ago by Jean-Paul Calderone

Cc: Jean-Paul Calderone added
Owner: changed from Glyph to radix

We should do something about this or resolve not to do anything about this. As far as I can tell, there are two things we could do about it:

  • create separate source distributions for different versions of python; exclude python 2.5-only features from the python 2.3 and python 2.4 distributions.
  • get rid of that source file from the source tree and have the tests write it out at runtime

Is it worth doing either of these? To be clear, this does not cause problems; it just confuses some users.

comment:5 Changed 9 years ago by ghazel

I saw this as well, and came here to file a ticket. We could use something like exec.diff, attached.

Changed 9 years ago by ghazel

Attachment: exec.diff added

exec-based answer

comment:6 Changed 9 years ago by Jean-Paul Calderone

Having blobs of code in strings isn't good.

comment:7 Changed 9 years ago by Thijs Triemstra

Cc: Thijs Triemstra added

comment:8 Changed 9 years ago by Thijs Triemstra

Priority: normalhigh

#3578 was a duplicate of this, which was related to 8.1.0 meaning it's still an issue with the latest release(s), so raising the priority of this ticket.

comment:9 Changed 9 years ago by therve

Priority: highnormal

As said before, this is not a problem, just an useless warning, so it doesn't deserver high priority.

comment:10 Changed 9 years ago by Thijs Triemstra

Lot of people run into it though which makes Twisted look broken to newbies, and it makes us having to close/review more tickets. I only raised the priority cause at least 3 users saw this issue and considered it serious enough to register and open a ticket on this site. But I understand your point though.

comment:11 Changed 9 years ago by jafo

Resolution: duplicate
Status: newclosed

This issue should be resolved by the changes currently in review for ticket 1696. The changes in that ticket cause the sdist command to check the Python version and if it's 2.4 or below it excludes the failing test from the sdist.

comment:12 Changed 7 years ago by <automation>

Owner: radix deleted
Note: See TracTickets for help on using tickets.