Opened 6 years ago

Closed 3 years ago

#3229 defect closed duplicate (duplicate)

Mention Deferred chaining limit in howto/defer.html

Reported by: Scramblejams Owned by: ivank
Priority: normal Milestone:
Component: core Keywords: documentation
Cc: thijs Branch:
Author: Launchpad Bug:

Description

Chaining more than ~250 deferreds results in a recursion error. See attached code for demonstration of the problem, and the following email for a description of why it occurs:

http://twistedmatrix.com/pipermail/twisted-python/2008-May/017681.html

(Note: You may have to play with NO_OF_DEFERREDS in the sample code. On my system, Python 2.5/Twisted 8.0.1, I needed to use 332. You may need more or fewer.)

In the meantime, or if this gets classified as wontfix, this issue should be covered in the deferred documentation, preferably here:

http://twistedmatrix.com/projects/core/documentation/howto/defer.html#auto11

Attachments (1)

foo.py (631 bytes) - added by Scramblejams 6 years ago.

Download all attachments as: .zip

Change History (6)

Changed 6 years ago by Scramblejams

comment:1 Changed 6 years ago by Scramblejams

  • Summary changed from Upgrade Deferred to support a callback chain of arbitrary length to Fix Deferred to support a callback chain of arbitrary length

comment:2 follow-up: Changed 5 years ago by ivank

  • Keywords documentation added
  • Summary changed from Fix Deferred to support a callback chain of arbitrary length to Mention Deferred chaining limit in howto/defer.html

This is a duplicate of #411, but this ticket mentions the documentation problem, so I'm turning this into a documentation-only bug.

comment:3 Changed 5 years ago by glyph

  • Owner changed from glyph to ivank

comment:4 in reply to: ↑ 2 Changed 3 years ago by thijs

  • Cc thijs added

Replying to ivank:

This is a duplicate of #411, but this ticket mentions the documentation problem, so I'm turning this into a documentation-only bug.

#411 is resolved and also fixed the problem, when increasing NO_OF_DEFERREDS to 1000 in the attached foo.py. Can this be closed?

comment:5 Changed 3 years ago by exarkun

  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.