Opened 10 years ago

Closed 10 years ago

#3195 defect closed duplicate (duplicate)

Concurrency issue in web.client

Reported by: LeifKB Owned by:
Priority: high Milestone:
Component: web Keywords:
Cc: Branch:
Author:

Description

The constructor of twisted.web.client sets the attribute "self.protocol.followRedirect". Since self.protocol is a class (HTTPPageGetter, specifically), it is shared by all instances of HTTPClientFactory. Thus, if multiple HTTP requests are taking place concurrently, they will share the same followRedirect value. This can be fixed by moving the code which sets followRedirect into the buildProtocol method, so that the attribute will be instance-specific.

Attachments (1)

patch.diff (877 bytes) - added by LeifKB 10 years ago.

Download all attachments as: .zip

Change History (3)

Changed 10 years ago by LeifKB

Attachment: patch.diff added

comment:1 Changed 10 years ago by Jean-Paul Calderone

Resolution: duplicate
Status: newclosed

Duplicate of #3192

comment:2 Changed 7 years ago by <automation>

Owner: jknight deleted
Note: See TracTickets for help on using tickets.