Opened 10 years ago

Closed 10 years ago

#3103 defect closed duplicate (duplicate)

web2 http server does nothing on connectionLost

Reported by: htj Owned by:
Priority: high Milestone: Web2-Gold-Master
Component: web2 Keywords:
Cc: Branch:
Author:

Description

The web2.http.Request.connectionLost is empty. This is problematic when a stream is active, as no cleanup gets done.

Furthermore the web.http._NotifyingProducerStream.finish method does not propagate failure correctly, and for some reason does not follow the stream interface, by not having a failure argument.

Attached patch fixes these two problems. Both of these fixes are needed for the server not to have any leftovers when connections are lost.

Attachments (1)

web2_http_connlost.diff (787 bytes) - added by htj 10 years ago.
Fixes cleanup when a connection is lost.

Download all attachments as: .zip

Change History (3)

Changed 10 years ago by htj

Attachment: web2_http_connlost.diff added

Fixes cleanup when a connection is lost.

comment:1 Changed 10 years ago by Jean-Paul Calderone

Resolution: duplicate
Status: newclosed

Duplicate of #3083

comment:2 Changed 7 years ago by <automation>

Owner: David Reid deleted
Note: See TracTickets for help on using tickets.