Opened 7 years ago

Closed 7 years ago

Last modified 5 years ago

#3096 defect closed wontfix (wontfix)

gtk2reactor consumes loads of CPU on Ubuntu Hardy after SIGCHLD

Reported by: niemeyer Owned by:
Priority: high Milestone:
Component: core Keywords:
Cc: Branch:
Author: Launchpad Bug:

Description

The simple attached script will consume a lot of CPU for as long as it runs in
the Ubuntu Hardy environment. I've tested it both with the Twisted version
currently in Hardy (2.5.0-2build2), and also with the current trunk
(revision 22957).

The issue is only reproducible with the glib2 reactor, and is not reproducible
in Ubuntu Gutsy (even with Twisted trunk), which hints about behavior change in
a dependency. It was also possible to execute the script a few times without
getting the bad behavior, which might indicate a race somewhere.

Attachments (2)

testcase.py (364 bytes) - added by niemeyer 7 years ago.
Test case
updated-testcase.py (266 bytes) - added by niemeyer 7 years ago.
Updated test case

Download all attachments as: .zip

Change History (8)

Changed 7 years ago by niemeyer

Test case

comment:1 Changed 7 years ago by niemeyer

  • Summary changed from getProcessOutput() consumes loads of CPU on Ubuntu Hardy to gtk2reactor consumes loads of CPU on Ubuntu Hardy after SIGCHLD

It turns out that the actual reason for the process to spin is the fact that it
receives a SIGCHLD or not. I'm attaching a new test case which reproduces the
problem consistently.

Changed 7 years ago by niemeyer

Updated test case

comment:2 Changed 7 years ago by radix

Apparently this is only being seen after a particular upgrade of glib2/pygtk:

Broken are:

  • libglib2.0-0_2.16.1-1ubuntu3_i386.deb
  • python-gobject_2.14.1-2_i386.deb

Working are:

  • libglib2.0-0_2.14.1-1ubuntu1_i386.deb
  • python-gobject_2.14.0-0ubuntu1_i386.deb

It may be that Twisted needs to be updated for an API change, or it may be a newly introduced bug. We should investigate exactly what changed between those releases.

comment:3 Changed 7 years ago by niemeyer

  • Resolution set to wontfix
  • Status changed from new to closed

Sebastien Bacher found out that the bug is introduced by the modification in pygtk's gobject
discussed in the following ticket:

http://bugzilla.gnome.org/show_bug.cgi?id=481569

comment:4 Changed 7 years ago by glyph

Hmm. I wonder if "wontfix" is really the right thing to say for tickets like this.

Is there a chance that we're going to need to work around this revision of gobject "in the wild"? Should we track the issue being dealt with in bugzilla?

(Grumble, grumble, I really need to write that intertracker protocol specification that I keep promising the launchpad guys I'll write one day...)

comment:5 Changed 5 years ago by exarkun

#3981 appears to have been a duplicate of this.

comment:6 Changed 4 years ago by <automation>

  • Owner glyph deleted
Note: See TracTickets for help on using tickets.