Opened 10 years ago

Closed 10 years ago

#3094 enhancement closed duplicate (duplicate)

Import illustrations into lore from Inkscape

Reported by: jelkner Owned by: pcardune
Priority: normal Milestone:
Component: lore Keywords:
Cc: Branch:
Author: jelkner

Description

Provide an import filter that will take an image generated by inkscape and format it as a compliant svg document for a document with the heading:

<!DOCTYPE html PUBLIC "-W3CDTD XHTML 1.1 plus MathML 2.0 plus SVG 1.1EN" "http://www.w3.org/2002/04/xhtml-math-svg/xhtml-math-svg.dtd"> <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" xmlns:svg="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink">

Change History (2)

comment:1 Changed 10 years ago by David Reid

Why can't you just save the documents as an SVG from Inkscape?

comment:2 Changed 10 years ago by radix

Resolution: duplicate
Status: newclosed

This isn't actually a distinct issue from #3093; inkscape's "basic SVG" format isn't different from SVG. Any implementation of #3093 will need to understand XML namespaces enough to re-root them to an "svg:" prefix (or whatever) when embedding them into the XHTML output.

Resolving as a duplicate of #3093.

Note: See TracTickets for help on using tickets.