Opened 6 years ago

Closed 5 years ago

#3088 enhancement closed duplicate (duplicate)

Make trial able to run tests and modules in a specific order

Reported by: amacleod Owned by:
Priority: normal Milestone:
Component: trial Keywords:
Cc: Branch:
Author: Launchpad Bug:

Description

When trying to track down some side-effects issues between test modules run by trial, I found myself wishing I could specify the order in which to run modules.

For instance, if I issued the command:

trial tests/test_monkey.py tests/test_uncle.py

I would like it to run the monkey tests first and then the uncle tests.

Even more whiz-bang would be a way to specify the order when running all test_ modules in a directory, with possible choices being alphabetical, by modification time, or random.

Change History (5)

comment:1 Changed 6 years ago by glyph

I could have sworn this was a duplicate of something, but I just looked for like an hour and couldn't find it. If not, this should definitely be fixed. I've had this problem myself.

comment:2 Changed 6 years ago by jml

Really, this is "parametrize the loader from the command line".

comment:3 Changed 6 years ago by glyph

#3249 was filed as a duplicate of this.

comment:4 Changed 5 years ago by Screwtape

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #1948 (thanks to PovAddict on #twisted for pointing it out)

comment:5 Changed 3 years ago by <automation>

  • Owner jml deleted
Note: See TracTickets for help on using tickets.