Opened 7 years ago

Closed 19 months ago

Last modified 19 months ago

#3070 defect closed wontfix (wontfix)

trial writes warnings to stdout

Reported by: exarkun Owned by:
Priority: normal Milestone:
Component: trial Keywords:
Cc: Branch:
Author: Launchpad Bug:

Description

This is weird because the default for warnings is to end up on stderr.

Another problem with this code is that it allows warnings to mess up the formatting done by the reporter. The runner really shouldn't be writing things to stdout, only the reporter should do that.

Change History (6)

comment:1 Changed 7 years ago by exarkun

(In [22777]) Ignore warnings logged in test_stdout

Refs #2941
Refs #3070

:(

comment:2 Changed 7 years ago by glyph

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #2820.

comment:3 Changed 4 years ago by <automation>

  • Owner jml deleted

comment:4 Changed 19 months ago by Julian

  • Resolution duplicate deleted
  • Status changed from closed to reopened

#2820 is closed, but this appears to still be true?

comment:5 Changed 19 months ago by glyph

  • Resolution set to wontfix
  • Status changed from reopened to closed

#2820 was really about the use of print as opposed to untilConcludes, not stdout vs. stderr.

I believe that trial ought to keep its current behavior because, as a testing tool, warnings are part of trial's useful output, they're not ancillary information. In fact, most warnings are suppressed in Python, not written to stderr, and Trial explicitly turns them back on in order to associate them with a particular test case.

comment:6 Changed 19 months ago by glyph

Since we're trying to refer to something more productive whenever we close a ticket, I was about to refer you to the ticket for making trial turn on warnings in python 2.7, but it looks like you've found it already. Thanks for working on it :).

Note: See TracTickets for help on using tickets.