Opened 9 years ago

Closed 8 years ago

Last modified 13 days ago

#3021 enhancement closed duplicate (duplicate)

Explain why Deferred.setTimeout is deprecated in documentation so people stop wondering.

Reported by: indigo Owned by:
Priority: normal Milestone:
Component: core Keywords: documentation
Cc: spiv, therve, thijs Branch:
Author:

Description


Attachments (1)

defer.diff (1.5 KB) - added by indigo 9 years ago.
doc patch

Download all attachments as: .zip

Change History (8)

Changed 9 years ago by indigo

doc patch

comment:1 Changed 9 years ago by spiv

  • Cc spiv added

Hasn't this been deprecated for ages? Why don't we just delete it? :)

comment:2 follow-up: Changed 9 years ago by therve

  • Cc therve added

#1702 shows that we are ourselves unable to remove it from Twisted. Making the assumption that our users can do better is probably wrong.

comment:3 in reply to: ↑ 2 Changed 8 years ago by thijs

  • Cc thijs added
  • Keywords documentation added

Replying to therve:

#1702 shows that we are ourselves unable to remove it from Twisted. Making the assumption that our users can do better is probably wrong.

So what to do, should we add (those patched) docs or not?

comment:4 Changed 8 years ago by cary

  • Keywords review added
  • Owner glyph deleted

Bumping this back to review status. Looks like the existing patch can just be applied as is?

comment:5 Changed 8 years ago by cary

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #1702

comment:6 Changed 6 years ago by <automation>

comment:7 Changed 13 days ago by hawkowl

  • Keywords review removed

[mass edit] Removing review from closed tickets.

Note: See TracTickets for help on using tickets.