Opened 6 years ago

Closed 6 years ago

#3018 enhancement closed invalid (invalid)

t.w2.r.Resource.addSlash = True should be the default behavior.

Reported by: dreid Owned by:
Priority: normal Milestone:
Component: web2 Keywords:
Cc: Branch:
Author: Launchpad Bug:

Description

addSlash toggles a very desirable redirect behavior for collection resources. I'm reasonably certain I've never wanted it set to false, however I'm assured by idnar that the HTTP request roundtrip caused by the redirect is undesirable in certain specific network conditions. So I propose that we change the default behavior to addSlash = True.

Change History (2)

comment:1 Changed 6 years ago by glyph

  • Resolution set to invalid
  • Status changed from new to closed

addSlash is a pretty confusing feature and probably should never have been added in the first place, at least in this manner. It certainly shouldn't be a base feature of Resource. Perhaps what you want is a specific resource.Collection object, which always does this, and a resource.Resource object, which never does, rather than a flag.

comment:2 Changed 3 years ago by <automation>

  • Owner dreid deleted
Note: See TracTickets for help on using tickets.