Opened 6 years ago

Closed 4 years ago

#3015 enhancement closed duplicate (duplicate)

StringIOWithoutClosing code duplicated in many test suites

Reported by: danderson Owned by:
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch:
Author: Launchpad Bug:

Description

StringIOWithoutClosing is reproduced, with slight variations, in two suites in twisted.test and three suites in twisted.words.test . The class should be factored out into a common helper in twisted.core. Actually, the common helper should build a StringIO transport, not just a tweaked StringIO, so that all tests properly use a real transport implementation (twisted.words currently has problems with this).

Change History (2)

comment:1 Changed 4 years ago by exarkun

  • Resolution set to duplicate
  • Status changed from new to closed

#3647 was a duplicate of this.

comment:2 Changed 3 years ago by <automation>

  • Owner glyph deleted
Note: See TracTickets for help on using tickets.