Opened 7 years ago

Closed 6 years ago

#3012 defect closed duplicate (duplicate)

twisted.internet._sslverify.CertificateOptions does not work with chained certs

Reported by: washort Owned by:
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch:
Author: Launchpad Bug:

Description

Some SSL certificates require intermediate certs to be loaded to make them acceptable to various clients. ctx.use_certificate_chain_file is the method for doing so -- unfortunately there seems to be no corresponding method for loading it from a string.

Change History (3)

comment:1 Changed 6 years ago by exarkun

There's SSL_CTX_add_extra_chain_cert. It's not exposed by PyOpenSSL.

comment:2 Changed 6 years ago by exarkun

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #2061

comment:3 Changed 3 years ago by <automation>

  • Owner exarkun deleted
Note: See TracTickets for help on using tickets.