Opened 7 years ago

Closed 6 years ago

#2984 enhancement closed duplicate (duplicate)

move all TODO'd tests into tickets, delete them from the test suite

Reported by: glyph Owned by:
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch:
Author: Launchpad Bug:

Description (last modified by glyph)

The "to do" feature of trial is problematic, because todo'd tests:

  • make the test output harder to read, because a completely successful run should not print tracebacks
  • increase the code size without adding any value, in other words, they're cruft
  • increase the run-time of the test suite without adding any value, because we expect them to fail
  • fail to record information about tasks which should be done in the ticket tracker, instead putting them in an ad-hoc format which is ignored

The tests themselves aren't completely valueless though, and should be attached individually to the tickets that they represent (or deleted, in the case that individual tests are actually completely valueless), so that they can be worked on, or if they're being ignored, there will be a record of the fact that they have been ignored. This is also true of any tests marked "skip" because they are actually "todo" but actually running them breaks the test suite.

Change History (4)

comment:1 Changed 7 years ago by glyph

  • Description modified (diff)

comment:2 Changed 7 years ago by glyph

  • Description modified (diff)

comment:3 Changed 6 years ago by exarkun

  • Resolution set to duplicate
  • Status changed from new to closed

This is basically a duplicate of #2001.

comment:4 Changed 4 years ago by <automation>

  • Owner exarkun deleted
Note: See TracTickets for help on using tickets.