Opened 10 years ago

Closed 8 years ago

#2978 enhancement closed duplicate (duplicate)

documentation unclear on how gtk2reactor applications should be started

Reported by: kleist Owned by:
Priority: normal Milestone:
Component: core Keywords: gtk2reactor documentation
Cc: Thijs Triemstra Branch:
Author:

Description

First of all, all you guys: THANKS! twisted.web.client + PyGTK is paradise compared with Java + Swing. I'm feeling ten times as productive.

However this was not an easy start, since the fact that reactor.run() should be used instead of gtk.main() is carefully hidden in the docs. I found that tip only in #691.

It would be very helpful to beginners if "twisted/internet/gtk2reactor.py" told that, and maybe "http://twistedmatrix.com/projects/core/documentation/howto/choosing-reactor.html#auto10" too.

Change History (4)

comment:1 Changed 10 years ago by Jean-Paul Calderone

Keywords: documentation added
Summary: documentation unclear on how gtk2reactor applications should be started

comment:2 Changed 10 years ago by Jean-Paul Calderone

The choosing-reactor howto does explain the requirement to call reactor.run() earlier on. Maybe it would be more obvious what is necessary if each section linked to a complete, working example of using that reactor.

comment:3 in reply to:  2 Changed 8 years ago by Thijs Triemstra

Cc: Thijs Triemstra added
Resolution: duplicate
Status: newclosed

Replying to exarkun:

The choosing-reactor howto does explain the requirement to call reactor.run() earlier on. Maybe it would be more obvious what is necessary if each section linked to a complete, working example of using that reactor.

Sounds like this is a duplicate of #3253 that was fixed recently. Closing ticket, please reopen if necessary.

comment:4 Changed 7 years ago by <automation>

Owner: Glyph deleted
Note: See TracTickets for help on using tickets.