Opened 10 years ago

Closed 10 years ago

#2961 enhancement closed duplicate (duplicate)

twisted.web2.dav.base.WebDAVElement defines __eq__ but no __hash__

Reported by: therve Owned by:
Priority: normal Milestone: Python-2.6
Component: web2.dav Keywords:
Cc: David Reid Branch:
Author:

Description

Due to a recent change on python trunk, this kind of modifications isn't allowed anymore. This also make the tests completely explodes. It should have a hash method that is build using the combined hash of its attributes.

Change History (4)

comment:1 Changed 10 years ago by therve

Milestone: Python-2.6

comment:2 Changed 10 years ago by therve

Cc: David Reid added

comment:3 Changed 10 years ago by Jean-Paul Calderone

Resolution: duplicate
Status: newclosed

Duplicate of #2960

comment:4 Changed 7 years ago by <automation>

Owner: Wilfredo Sánchez Vega deleted
Note: See TracTickets for help on using tickets.