Opened 10 years ago

Closed 10 years ago

#2946 enhancement closed duplicate (duplicate)

implement an update-capable (RFC 2136) twisted.names server

Reported by: Jean-Paul Calderone Owned by:
Priority: low Milestone:
Component: names Keywords:
Cc: Branch:
Author:

Description

RFC 2136 allows the records of a zone to be updated by sending UPDATE ops to a server.

Change History (4)

comment:1 Changed 10 years ago by Jean-Paul Calderone

(In [22066]) Merge dns-notify-update-2945

Author: exarkun Reviewer: therve Fixes #2945 Refs #2946

Fix the value of OP_NOTIFY in twisted.names.dns and add a definition for OP_UPDATE. Add unit tests for the top-level handling of messages with these opcodes and fix an unrelated incorrectly named/defined test method so that it doesn't occult another test method.

comment:2 Changed 10 years ago by Jean-Paul Calderone

Duplicate of #2499

comment:3 Changed 10 years ago by Jean-Paul Calderone

Resolution: duplicate
Status: newclosed

comment:4 Changed 7 years ago by <automation>

Owner: Jean-Paul Calderone deleted
Note: See TracTickets for help on using tickets.