Opened 7 years ago

Closed 6 years ago

#2882 defect closed duplicate (duplicate)

test_process hanging on vista slave (popup)-

Reported by: bigdog Owned by:
Priority: highest Milestone:
Component: core Keywords:
Cc: Branch:
Author: Launchpad Bug:

Description

It seems the env is null for the child processes launched in test_process.

On the iocp vista slave, this is causing a pop-up hang for the bot.

(I put it hightest, because of the bot hang)

Change History (6)

comment:1 Changed 7 years ago by bigdog

EMV Vars for Visa Slave

C:\pythonpkgs\twisted>set
ALLUSERSPROFILE=C:\Documents and Settings\All Users
APPDATA=C:\Documents and Settings\scmikes\Application Data
APR_ICONV_PATH=C:\Program Files\Subversion\iconv
CLASSPATH=.;C:\Program Files\Java\jre1.6.0_02\lib\ext\QTJava.zip
CLIENTNAME=Console
CommonProgramFiles=C:\Program Files\Common Files
COMPUTERNAME=BAXTER
ComSpec=C:\WINDOWS\system32\cmd.exe
FP_NO_HOST_CHECK=NO
GTK_BASEPATH=C:\GTK
HOMEDRIVE=C:
HOMEPATH=\Documents and Settings\scmikes
INCLUDE=c:\Program Files\Microsoft Visual Studio .NET 2003\SDK\v1.1\include\
LIB=c:\Program Files\Microsoft Visual Studio .NET 2003\SDK\v1.1\Lib\
LOGONSERVER=
BAXTER
NUMBER_OF_PROCESSORS=4
OS=Windows_NT
Path=C:\GTK\bin;C:\Program Files\MiKTeX 2.7\miktex\bin;C:\WINDOWS\system32;C:\WI
NDOWS;C:\WINDOWS\System32\Wbem;C:\Program Files\Subversion\bin;C:\Program Files\
MySQL\MySQL Server 5.1\bin;c:\python25;c:\python25\Scripts;c:\mingw\bin;C:\Progr
am Files\Microsoft SQL Server\90\Tools\binn\;C:\Program Files\QuickTime\QTSystem
\;C:\Program Files\Bazaar;c:\bin;
PATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH
PROCESSOR_ARCHITECTURE=x86
PROCESSOR_IDENTIFIER=x86 Family 6 Model 15 Stepping 7, GenuineIntel
PROCESSOR_LEVEL=6
PROCESSOR_REVISION=0f07
ProgramFiles=C:\Program Files
PROMPT=$P$G
QTJAVA=C:\Program Files\Java\jre1.6.0_02\lib\ext\QTJava.zip
SESSIONNAME=Console
SystemDrive=C:
SystemRoot=C:\WINDOWS
TEMP=C:\DOCUME~1\scmikes\LOCALS~1\Temp
TMP=C:\DOCUME~1\scmikes\LOCALS~1\Temp
UGII_LICENSE_FILE=27000@baxter;27000@baxter
USERDOMAIN=BAXTER
USERNAME=scmikes
USERPROFILE=C:\Documents and Settings\scmikes
VS71COMNTOOLS=C:\Program Files\Microsoft Visual Studio .NET 2003\Common7\Tools\
VS80COMNTOOLS=C:\Program Files\Microsoft Visual Studio 8\Common7\Tools\
windir=C:\WINDOWS

comment:2 Changed 7 years ago by bigdog

re-submiteed env vars as code block, sorry

C:\pythonpkgs\twisted>set
ALLUSERSPROFILE=C:\Documents and Settings\All Users
APPDATA=C:\Documents and Settings\scmikes\Application Data
APR_ICONV_PATH=C:\Program Files\Subversion\iconv
CLASSPATH=.;C:\Program Files\Java\jre1.6.0_02\lib\ext\QTJava.zip
CLIENTNAME=Console
CommonProgramFiles=C:\Program Files\Common Files
COMPUTERNAME=BAXTER
ComSpec=C:\WINDOWS\system32\cmd.exe
FP_NO_HOST_CHECK=NO
GTK_BASEPATH=C:\GTK
HOMEDRIVE=C:
HOMEPATH=\Documents and Settings\scmikes
INCLUDE=c:\Program Files\Microsoft Visual Studio .NET 2003\SDK\v1.1\include\
LIB=c:\Program Files\Microsoft Visual Studio .NET 2003\SDK\v1.1\Lib\
LOGONSERVER=\\BAXTER
NUMBER_OF_PROCESSORS=4
OS=Windows_NT
Path=C:\GTK\bin;C:\Program Files\MiKTeX 2.7\miktex\bin;C:\WINDOWS\system32;C:\WI
NDOWS;C:\WINDOWS\System32\Wbem;C:\Program Files\Subversion\bin;C:\Program Files\
MySQL\MySQL Server 5.1\bin;c:\python25;c:\python25\Scripts;c:\mingw\bin;C:\Progr
am Files\Microsoft SQL Server\90\Tools\binn\;C:\Program Files\QuickTime\QTSystem
\;C:\Program Files\Bazaar;c:\bin;
PATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH
PROCESSOR_ARCHITECTURE=x86
PROCESSOR_IDENTIFIER=x86 Family 6 Model 15 Stepping 7, GenuineIntel
PROCESSOR_LEVEL=6
PROCESSOR_REVISION=0f07
ProgramFiles=C:\Program Files
PROMPT=$P$G
QTJAVA=C:\Program Files\Java\jre1.6.0_02\lib\ext\QTJava.zip
SESSIONNAME=Console
SystemDrive=C:
SystemRoot=C:\WINDOWS
TEMP=C:\DOCUME~1\scmikes\LOCALS~1\Temp
TMP=C:\DOCUME~1\scmikes\LOCALS~1\Temp
UGII_LICENSE_FILE=27000@baxter;27000@baxter
USERDOMAIN=BAXTER
USERNAME=scmikes
USERPROFILE=C:\Documents and Settings\scmikes
VS71COMNTOOLS=C:\Program Files\Microsoft Visual Studio .NET 2003\Common7\Tools\
VS80COMNTOOLS=C:\Program Files\Microsoft Visual Studio 8\Common7\Tools\
windir=C:\WINDOWS

comment:3 Changed 7 years ago by bigdog

  • Resolution set to worksforme
  • Status changed from new to closed

Don't know if this is a problem, the commands that I rely on seem to work:

(11:59:20 AM) bigdog_: vista 64 ultimate, python 32
(11:59:36 AM) bigdog_: god help the poor souls that rely on raw python
(11:59:41 AM) bigdog_: if you are a twisted user
(11:59:47 AM) bigdog_: >>> from twisted.python.runtime import platformType,platform
(11:59:47 AM) bigdog_: >>> platformType
(11:59:47 AM) bigdog_: 'win32'
(11:59:47 AM) bigdog_: >>> platform.isWindows()
(11:59:47 AM) bigdog_: True
(11:59:47 AM) bigdog_: >>>

comment:4 Changed 7 years ago by therve

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Wrong ticket :).

comment:5 Changed 6 years ago by PenguinOfDoom

  • Resolution set to duplicate
  • Status changed from reopened to closed

duplicate of #2948

comment:6 Changed 3 years ago by <automation>

  • Owner exarkun deleted
Note: See TracTickets for help on using tickets.