Opened 10 years ago

Closed 9 years ago

#2879 defect closed duplicate (duplicate)

twisted.test.test_pb.BrokerTestCase.test_publishable fails on windows sometimes

Reported by: Jean-Paul Calderone Owned by:
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch:
Author:

Description

Exciting traceback:

===============================================================================
[ERROR]: twisted.test.test_pb.BrokerTestCase.test_publishable

Traceback (most recent call last):
  File "c:\twistedbuildbot24\WXP32-full2.5-scmikes-select\Twisted\twisted\test\test_pb.py", line 732, in test_publishable
    pump.flush()
  File "c:\twistedbuildbot24\WXP32-full2.5-scmikes-select\Twisted\twisted\test\test_pb.py", line 71, in flush
    while self.pump():
  File "c:\twistedbuildbot24\WXP32-full2.5-scmikes-select\Twisted\twisted\test\test_pb.py", line 94, in pump
    self.client.dataReceived(byte)
  File "c:\twistedbuildbot24\WXP32-full2.5-scmikes-select\Twisted\twisted\spread\banana.py", line 218, in dataReceived
    gotItem(item)
  File "c:\twistedbuildbot24\WXP32-full2.5-scmikes-select\Twisted\twisted\spread\banana.py", line 148, in gotItem
    self.callExpressionReceived(item)
  File "c:\twistedbuildbot24\WXP32-full2.5-scmikes-select\Twisted\twisted\spread\banana.py", line 113, in callExpressionReceived
    self.expressionReceived(obj)
  File "c:\twistedbuildbot24\WXP32-full2.5-scmikes-select\Twisted\twisted\spread\pb.py", line 522, in expressionReceived
    method(*sexp[1:])
  File "c:\twistedbuildbot24\WXP32-full2.5-scmikes-select\Twisted\twisted\spread\pb.py", line 891, in proto_answer
    d.callback(self.unserialize(netResult))
  File "c:\twistedbuildbot24\WXP32-full2.5-scmikes-select\Twisted\twisted\spread\pb.py", line 783, in unserialize
    return unjelly(sexp, self.security, None, self)
  File "c:\twistedbuildbot24\WXP32-full2.5-scmikes-select\Twisted\twisted\spread\jelly.py", line 900, in unjelly
    return _Unjellier(taster, persistentLoad, invoker).unjellyFull(sexp)
  File "c:\twistedbuildbot24\WXP32-full2.5-scmikes-select\Twisted\twisted\spread\jelly.py", line 523, in unjellyFull
    o = self.unjelly(obj)
  File "c:\twistedbuildbot24\WXP32-full2.5-scmikes-select\Twisted\twisted\spread\jelly.py", line 546, in unjelly
    val = method(self, obj)
  File "c:\twistedbuildbot24\WXP32-full2.5-scmikes-select\Twisted\twisted\spread\flavors.py", line 458, in unjellyFor
    cProxy.setCopyableState(unjellier.unjelly(jellyList[2]))
  File "c:\twistedbuildbot24\WXP32-full2.5-scmikes-select\Twisted\twisted\spread\publish.py", line 86, in setCopyableState
    newself = jelly.unjelly(banana.decode(data))
  File "c:\twistedbuildbot24\WXP32-full2.5-scmikes-select\Twisted\twisted\spread\banana.py", line 353, in decode
    return l[0]
exceptions.IndexError: list index out of range
-------------------------------------------------------------------------------

Change History (2)

comment:1 Changed 9 years ago by Jean-Paul Calderone

Resolution: duplicate
Status: newclosed

Duplicate of #2327

comment:2 Changed 7 years ago by <automation>

Owner: Glyph deleted
Note: See TracTickets for help on using tickets.