Opened 7 years ago

Closed 6 years ago

#2878 defect closed fixed (fixed)

Intermittent unclean errors from twisted.test.test_ftp.FTPServerPasvDataConnectionTestCase.testTwoDirLIST on OS X

Reported by: exarkun Owned by:
Priority: high Milestone:
Component: core Keywords:
Cc: Branch: branches/ftp-test-cleanup-2878
(diff, github, buildbot, log)
Author: exarkun Launchpad Bug:

Description

Seen occassionally:

===============================================================================
[ERROR]: twisted.test.test_ftp.FTPServerPasvDataConnectionTestCase.testTwoDirLIST

Traceback (most recent call last):
Failure: twisted.trial.util.DirtyReactorAggregateError: Reactor was unclean.
DelayedCalls: (set twisted.internet.base.DelayedCall.debug = True to debug)
<DelayedCall 57837128 [599.546686888s] called=0 cancelled=0 FTP.__timedOut()>
===============================================================================
[ERROR]: twisted.test.test_ftp.FTPServerPasvDataConnectionTestCase.testTwoDirLIST

Traceback (most recent call last):
Failure: twisted.trial.util.DirtyReactorAggregateError: Reactor was unclean.
Selectables:
<ProtocolWrapper #0 on 61530>
<<class 'twisted.internet.tcp.Port'> of twisted.protocols.ftp.DTPFactory on 61538>
-------------------------------------------------------------------------------

Change History (7)

comment:1 Changed 6 years ago by exarkun

  • Priority changed from normal to high

A cleanup error occurs on OS X with another FTP test as well:

===============================================================================
[ERROR]: twisted.test.test_ftp.BasicFTPServerTestCase.testAnonymousLoginDenied

Traceback (most recent call last):
Failure: twisted.trial.util.DirtyReactorAggregateError: Reactor was unclean.
DelayedCalls: (set twisted.internet.base.DelayedCall.debug = True to debug)
<DelayedCall 72203320 [599.86994195s] called=0 cancelled=0 FTP.__timedOut()>
===============================================================================
[ERROR]: twisted.test.test_ftp.BasicFTPServerTestCase.testAnonymousLoginDenied

Traceback (most recent call last):
Failure: twisted.trial.util.DirtyReactorAggregateError: Reactor was unclean.
Selectables:
<ProtocolWrapper #0 on 57297>
-------------------------------------------------------------------------------

comment:2 Changed 6 years ago by exarkun

  • author set to exarkun
  • Branch set to branches/ftp-test-cleanup-2878

(In [24790]) Branching to 'ftp-test-cleanup-2878'

comment:3 Changed 6 years ago by exarkun

#3405 was a duplicate of this, for the testManyLargeDownloads method.

comment:4 Changed 6 years ago by exarkun

  • Keywords review added
  • Owner glyph deleted

I think this is fixed.

comment:5 Changed 6 years ago by therve

  • Keywords review removed
  • Owner set to exarkun

Please merge.

comment:6 Changed 6 years ago by exarkun

  • Resolution set to fixed
  • Status changed from new to closed

(In [24811]) Merge ftp-test-cleanup-2878

Author: exarkun
Reviewer: therve
Fixes: #2878

Change the setUp of one of the base FTP test cases so that
the test will wait for the server-side of any FTP connection
established in the test to disconnect before ending the test,
avoiding leaving a selectable in the reactor for trial to
find and emit an unclean error for.

comment:7 Changed 4 years ago by <automation>

  • Owner exarkun deleted
Note: See TracTickets for help on using tickets.