Opened 7 years ago

Closed 4 years ago

#2812 enhancement closed duplicate (duplicate)

cfreactor replacement using threadedselectreactor

Reported by: termie Owned by: termie
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch:
Author: Launchpad Bug:

Description

Everything I can find on cfreactor here seems to be made years ago, the thing seems pretty buggy and quite large (I have to install cfsupport separately?)

The attached file is a quick implementation based off wxreactor and some examples using PyObjCTools.AppHelper to move things along.

Seems pretty straightforward based on the examples I've seen, but I'm not familiar enough with the reactor infrastructure to know what may be missing.

Attachments (1)

cocoareactor.py (3.2 KB) - added by termie 7 years ago.

Download all attachments as: .zip

Change History (5)

Changed 7 years ago by termie

comment:1 Changed 7 years ago by exarkun

For anyone wondering about this ticket, it's waiting for:

  1. unit tests
  2. a build slave

This code may well be better than the existing cfreactor (I haven't looked closely at either), so don't interpret this comment as a suggestion that it isn't. However, we have no way of knowing until the above two things are supplied.

comment:2 Changed 5 years ago by glyph

  • Owner changed from glyph to termie

comment:3 Changed 4 years ago by glyph

Poke, poke. Hello, termie.

comment:4 Changed 4 years ago by glyph

  • Resolution set to duplicate
  • Status changed from new to closed

Oh, awesome, I can close this: it looks like it is a duplicate of #1833.

Note: See TracTickets for help on using tickets.