Opened 10 years ago

Closed 10 years ago

#2796 defect closed duplicate (duplicate)

trial should not print tracebacks for expected failures

Reported by: spiv Owned by:
Priority: normal Milestone:
Component: trial Keywords:
Cc: Branch:
Author:

Description

If a test produces an expected failure, then it did what it was expected to do. So I don't really care about it much more than a success. I certainly don't want dozens of lines of uninteresting traceback spamming my terminal, at least not by default.

Maybe summarise just the names of the expected failure tests at the end, rather than printing a full "failure"? Or just let people scan for TODO in the reporter output.

Change History (2)

comment:1 Changed 10 years ago by Tristan Seligmann

Resolution: duplicate
Status: newclosed

dupe of #2795

comment:2 Changed 7 years ago by <automation>

Owner: Jonathan Lange deleted
Note: See TracTickets for help on using tickets.