Opened 7 years ago

Closed 5 years ago

#2720 enhancement closed duplicate (duplicate)

merge all deferreds howtos into one that doesn't suck

Reported by: itamarst Owned by:
Priority: normal Milestone:
Component: core Keywords: documentation
Cc: glyph, exarkun Branch:
Author: Launchpad Bug:

Description


Change History (6)

comment:1 Changed 7 years ago by moonfallen

I would like to see information about advanced techniques such as inlineCallbacks and DeferredQueue included.

comment:2 Changed 7 years ago by glyph

  • Owner changed from glyph to itamarst

I very much would not. We need at least 2 Deferred howtos, one for beginners which does not discuss any advanced techniques and tries very hard just to communicate the basics, and then one for more advanced and nuanced stuff. Probably we need an entire document describing each of inlineCallbacks, DeferredQueue, DeferredSemaphore, etc.

Frankly, I think this ticket is ridiculously broad and has no hope of ever getting closed, because the metric for "doesn't suck" is basically impossible to evaluate.

comment:3 Changed 6 years ago by itamarst

Let me be more specific then - I am proposing a single document with following structure, starting from simple to more complex, the idea being to ease people into it:

  1. Handwaving: "Deferreds are a promise"
  2. Using Deferreds the easy way - inlineCallbacks/deferredGenerator. The need for yield gets across some of implications of deferred result.
  3. Using Deferreds without layer of abstraction.
  4. Creating Deferreds.

And then maybe other howto for more "expert" or possibly utility stuff like gatherResults, DeferredQueue, etc..

comment:4 Changed 6 years ago by itamarst

  • Cc glyph exarkun added

comment:5 Changed 5 years ago by rotund

  • Resolution set to duplicate
  • Status changed from new to closed

Marking as duplicate of Issue #1148 to keep all this discussion in a single ticket.

comment:6 Changed 4 years ago by <automation>

  • Owner itamarst deleted
Note: See TracTickets for help on using tickets.