Opened 10 years ago

Closed 10 years ago

#2718 defect closed duplicate (duplicate)

async howto implies Deferreds solve concurrency issues

Reported by: itamarst Owned by:
Priority: normal Milestone:
Component: core Keywords: documentation
Cc: Branch:
Author:

Description

It is the second class of concurrency problem — non-computationally intensive tasks that involve an appreciable delay
— that Deferreds are designed to help solve. Functions that wait on hard drive access, database access, and network
access all fall into this class, although the time delay varies.

...

The basic idea behind Deferreds, and other solutions to this problem, is to keep the CPU as active as possible.

I think this howto is somewhat misleading and sorta implies that Deferreds have something to do with Twisted's concurrency model, a confusion many new users have.

Change History (2)

comment:1 Changed 10 years ago by therve

Resolution: duplicate
Status: newclosed

Duplicate of #2719.

comment:2 Changed 7 years ago by <automation>

Owner: Glyph deleted
Note: See TracTickets for help on using tickets.