Opened 7 years ago

Closed 4 years ago

#2714 enhancement closed duplicate (duplicate)

Add http_proxy and https_proxy support to web/client.py

Reported by: fsteinel Owned by:
Priority: normal Milestone:
Component: web Keywords: httpclient
Cc: Branch:
Author: Launchpad Bug:

Description


Change History (10)

comment:1 Changed 7 years ago by fsteinel

for unix:
http_proxy=os.environhttp_proxy?
https_proxy=os.environhttps_proxy?

comment:2 Changed 7 years ago by fsteinel

see also Issue #1895

comment:3 Changed 7 years ago by fsteinel

and Issue #463 with Issue #885

comment:4 Changed 7 years ago by itamarst

Personally I'd be happier if more work went into finishing web2, rather than improving web.

comment:5 Changed 7 years ago by exarkun

Plenty of people are using web right now. Ignoring their use-cases because maybe someday web2 will be usable strikes me as a bad idea.

comment:6 Changed 7 years ago by ghazel

and #1774

comment:7 Changed 6 years ago by exarkun

  • Keywords httpclient added

comment:8 Changed 5 years ago by exarkun

If someone really wants to add this to getPage (as I suspect the original reporter had intended), that's fine. However, I think it would be much more productive to add this as an Agent-alike instead.

comment:9 Changed 4 years ago by exarkun

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #1774, actually.

comment:10 Changed 3 years ago by <automation>

  • Owner jknight deleted
Note: See TracTickets for help on using tickets.